当前位置:主页 > 财经 > 正文

四线开花

2021-04-03 15:57

四线开花 

大神麻煩幫我寫一個周線底部四線開花 日線kdj j值<-5的選股公式,非常感謝㈴...

哦,四線開花這個選股公式比較麻煩。

請幫我編寫一個 通達信用的 並三線開花指標 謝謝

搜一下吧,應該能找到

請高手幫助:股票中的四線開花,指的是四線

5日線
10日線
30日線
60日線

通達信的選股公式,高手幫忙看看我應該怎麼導入才對?越詳細越好。

Ctrl+f——新建

日均線差值公式 ma5減上一日ma5值; ma10減上一日ma10值;

我沒有交易軟件上面編程公式能力,不過我經常使用EXCEL來做均線方面的計算,我就拿EXCEL的媒介來回答:
問題1:ma5減上一日ma5值
答:因為MA5是五日均線,五日均線就是計算得出的指數日線中的五天平均值,所以先求五日均線指標:公式:(周一收盤價+周二收盤價+周三收盤價+周四收盤價+周五收盤價)/ 5 。說明:前面的“周一到周五”隻是個時間周期概念,可以隨意按照你所希望的時間點來代入套用。根據上面公式就能得出五日均線當天或者指定某時段的值。要想知道 ma5減上一日ma5值,就必須計算今天和昨天的五日均線值,然後今天的減去昨天的,就能得出一天之間的差值。

問題2:ma10減上一日ma10值,不用復雜的回答,就是按照上面的方式計算十日均線,然後今天的值減去昨天的值。OK

我想把兩個附圖公式和 MA2六條均線組合成一個指標!希望您能幫忙!謝謝瞭!

MA1:MA(CLOSE,M1);
MA2:MA(CLOSE,M2);
MA3:MA(CLOSE,M3);
MA4:MA(CLOSE,M4);
MA5:MA(CLOSE,M5);
MA6:MA(CLOSE,M6);
VAR11:=EMA(EMA(C,9),9);
控盤:=(VAR11-REF(VAR11,1))/REF(VAR11,1)*1000;
VAR22:=100*WINNER(C*0.95);
STICKLINE(控盤>REF(控盤,1) AND 控盤>0,O,C,1.5,0),COLORFF00FF;
VAR1:=C-REF(C,1);
VAR2:=100*EMA(EMA(VAR1,6),6)/EMA(EMA(ABS(VAR1),6),6);
M5:=EMA(C,5);
MA13:=EMA(C,13);
UP:=DRAWLINE(L=LLV(L,BARSLAST(CROSS(MA13,M5))+1),LLV(L,BARSLAST(CROSS
(MA13,M5))+1),H=HHV(H,BARSLAST(CROSS(M5,MA13))+1),HHV(H,BARSLAST(CROSS
(M5,MA13))+1),0);
DOWN:=DRAWLINE(H=HHV(H,BARSLAST(CROSS(M5,MA13))+1),HHV(H,BARSLAST(CROSS
(M5,MA13))+1),L=LLV(L,BARSLAST(CROSS(MA13,M5))+1),LLV(L,BARSLAST(CROSS
(MA13,M5))+1),0);
BT:=(LLV(VAR2,2)=LLV(VAR2,7) AND COUNT(VAR2<0,2) AND CROSS(VAR2,MA(VAR2,2))) AND
REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1);
DRAWTEXT(BT,L*0.99,'↑短牛'),COLOR0000FF;
TJ1:=REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1) AND C<HHV(H,21)*0.82;
DRAWTEXT(TJ1,L*0.99,'↑中牛'),COLORFF00FF;
HR:=HHV(HIGH,55);
HRY:=LLV(LOW,55);
HRY11:=HR*HRY;
HRY33:=SQRT(HRY11);
TJ2:=REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1) AND C<HRY33;
DRAWTEXT(TJ2,L*0.97,'↑大牛'),COLOR00FFFF;
ST:=REF(UP,1)>REF(UP,2) AND DOWN<REF(UP,1);
DRAWTEXT(ST,H*1.03,'↓賣'),COLOR00FF00;
M1-M6是自定義均線的參數,自設。
PS:怎麼又是你?呵呵,又按你要求修改瞭,以後想好瞭再問哈。